Back to overview
Downtime
Web server undergoing unscheduled maintenance
Jun 1, 2022 at 11:16am UTC
Affected services
nexus
Resolved
Jun 4, 2022 at 5:12am UTC
All services have now been restored.
Affected services
Created
Jun 1, 2022 at 11:16am UTC
Engineers are working on the server to restore services as soon as possible.
Affected services