Back to overview
Downtime
Unscheduled Server Maintenance
May 14, 2022 at 10:54pm UTC
Resolved
May 14, 2022 at 11:40pm UTC
All services now resolved.
Affected services
Updated
May 14, 2022 at 11:03pm UTC
Our unresponsive server is now back online.
Affected services
Created
May 14, 2022 at 10:54pm UTC
Our team are working to resolve an issue on one of our web servers becoming non-responsive.
Affected services