Get in touch
Back
Degraded

Unscheduled Server Maintenance

Started 22 Feb at 05:20pm NZDT, resolved 22 Feb at 06:32pm NZDT.

nexus
Resolved

The instability issues we faced shortly before 5pm that affected websites has now been resolved. All systems are now running smoothly.

Posted 22 Feb at 06:32pm NZDT.
Created

We're in the process of resolving some issues on our server that causing some instability. We're working to resolve this within the hour.

Posted 22 Feb at 05:20pm NZDT.